














CHAPTER 8: EDA TOOL SUPPORT

EDA SIMULATION TOOLS

110 ■ INTRODUCTION TO THE QUARTUS II SOFTWARE ALTERA CORPORATION

Figure 2. Simulation Flow

The EDA Netlist Writer module of the Quartus II software generates VHDL 
Output Files (.vho) and Verilog Output Files (.vo) for performing functional 
or timing simulation, and Standard Delay Format Output Files (.sdo) that 
are required for performing timing simulation with EDA simulation tools. 
The Quartus II software generates SDF Output Files in Standard Delay 
Format version 2.1. The EDA Netlist Writer places simulation output files in 
a tool-specific directory under the current project directory.

In addition, the Quartus II software offers seamless integration for timing 
simulation with EDA simulation tools through the NativeLink feature. The 
NativeLink feature allows the Quartus II software to pass information to 
EDA simulation tools, and to launch EDA simulation tools from within the 
Quartus II software.

Generating Simulation Output Files

You can run the EDA Netlist Writer module to generate Verilog Output Files 
and VHDL Output Files by specifying EDA tool settings and compiling the 
design. If you have already compiled a design in the Quartus II software, 
you can specify different simulation output settings in the Quartus II 
software (for example, a different simulation tool) and then regenerate the 
Verilog Output Files or VHDL Output Files by clicking Start EDA Netlist 
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Writer on the Processing menu. If you are using the NativeLink feature, you 
can also run a simulation after an initial compilation with the Run EDA 
Simulation Tool command on the Tools menu.

The Quartus II software also allows you to generate the following types of 
output files for use in performing functional and timing simulation in EDA 
simulation tools:

■ Test Bench Files: You can create Verilog Test Bench Files (.vt) and 
VHDL Test Bench Files (.vht) for use with EDA simulation tools from a 
Vector Waveform File (.vwf) in the Quartus II Waveform Editor, using 
the Export command on the File menu. Verilog HDL and VHDL Test 
Bench Files are test bench template files that contain an instantiation of 
the top-level design file and test vectors from the Vector Waveform File. 
You can also generate self-checking test bench files if you specify the 
expected values in the Vector Waveform File.

■ Memory Initialization Files: You can use the Quartus II Memory 
Editor to enter the initial contents of a memory block, for example, 
content-addressable memory (CAM), RAM, or ROM, in a Memory 
Initialization File (.mif) or a Hexadecimal (Intel-Format) File (.hex).

■ Signal Activity Files: You can create Signal Activity Files for use with 
the PowerPlay Power Analyzer. A Signal Activity File contains toggle 
rate and static probability data for a design. You can specify a limit for 
the signal activity period, and can also specify that glitch filtering can 
be performed.

Simulation Libraries

Altera provides functional simulation libraries for designs that contain 
Altera-specific components, and atom-based timing simulation libraries for 
designs compiled in the Quartus II software. You can use these libraries to 
perform functional or timing simulation of any design with Altera-specific 
components in EDA simulation tools that are supported by the Quartus II 
software. Additionally, Altera provides pre-compiled functional and timing 
simulation libraries for simulation in the ModelSim-Altera software.

Altera provides functional simulation libraries for designs that use Altera 
megafunctions and standard library of parameterized modules (LPM) 
functions. Altera also provides pre-compiled versions of the altera_mf and 
220model libraries for simulation in the ModelSim software. 
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In the Quartus II software, the information for specific device architecture 
entities and megafunctions is located in post-routing atom-based timing 
simulation libraries. The timing simulation library files differ based on 
device family and whether you are using Verilog Output Files or VHDL 
Output Files. For VHDL designs, Altera provides VHDL Component 
Declaration files for designs with Altera-specific megafunctions.

Timing Analysis with EDA Tools
The Quartus II software supports timing analysis and minimum timing 
analysis with the Synopsys PrimeTime software on Linux and board-level 
timing analysis with the Mentor Graphics Tau board-level verification tools. 

To generate the necessary output files for performing timing analysis in 
EDA timing analysis tools, specify the appropriate timing analysis tool in 
the Timing Analysis and Board-Level pages under EDA Tool Settings in 
the Settings dialog box, and then perform a full compilation.

You can also generate the files by pointing to Start on the Processing menu, 
and then clicking Start EDA Netlist Writer after an initial compilation. If 
you are using the NativeLink feature, you can also run a timing analysis 
after an initial compilation by clicking Run EDA Timing Analysis Tool on 
the Tools menu.

f For Information About Refer To

Functional Simulation libraries 
included with the Quartus II software

“Altera Functional Simulation Libraries” in 
Quartus II Help

Performing simulation using the 
ModelSim or ModelSim-Altera software

Mentor Graphics ModelSim Support chapter 
in volume 3 of the Quartus II Handbook

Performing simulation with the VCS 
software

Synopsys VCS and VCS-MX Support chapter 
in volume 3 of the Quartus II Handbook

Performing simulation with the 
Cadence Incisive Enterprise Simulator 
software

Cadence NC-Sim Support chapter in 
volume 3 of the Quartus II Handbook

Performing simulation with the Aldec 
Active-HDL software

Aldec Active HDL Support chapter in 
volume 3 of the Quartus II Handbook

Performing simulation of Altera IP with 
EDA tools

Simulating Altera IP in Third-Party 
Simulation Tools chapter in volume 3 of the 
Quartus II Handbook
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Using the PrimeTime Software

The Quartus II software generates a Verilog Output File or VHDL Output 
File, a Standard Delay Format Output File (.sdo) that contains timing delay 
information, and a Tcl Script File (.tcl) that sets up the PrimeTime 
environment. 

With the NativeLink feature, you can specify that the Quartus II software 
launches the PrimeTime software in either command-line or GUI mode. You 
can also specify a Synopsys Design Constraints File that contains timing 
assignments for use in the PrimeTime software. 

The following steps describe the basic flow to manually use the PrimeTime 
software to perform timing analysis on a design after compilation in the 
Quartus II software:

1. Specify EDA tool settings, either in the Settings dialog box on the 
Assignments menu, or during project setup, with the New Project 
Wizard on the File menu.

2. Compile your design in the Quartus II software to generate the output 
netlist files. The Quartus II software places the files in a tool-specific 
directory.

3. Source the Quartus II-generated Tcl Script File to set up the PrimeTime 
environment.

4. Perform timing analysis in the PrimeTime software.

Using the Tau Software

The Quartus II software generates STAMP model files that can be imported 
into the Tau software to perform board-level timing verification.

The following steps describe the basic flow for generating STAMP model 
files:

1. Specify EDA tool settings, either in the Settings dialog box on the 
Assignments menu, or during project setup, using the New Project 
Wizard on the File menu.
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2. Compile the design in the Quartus II software to generate the STAMP 
model files. The Quartus II software places the files in a tool-specific 
directory.

3. Use the STAMP model files in the Tau software to perform board-level 
timing verification.

Formal Verification
The Quartus II software allows you to use formal verification EDA tools to 
verify the logical equivalence between source design files and Quartus II 
output files. Figure 3 shows the formal verification flow.

f For Information About Refer To

Using the Synopsys PrimeTime 
software with the Quartus II software

Synopsys PrimeTime Support chapter in 
volume 3 of the Quartus II Handbook

Using the Mentor Graphics Tau 
software with the Quartus II software

“About Using the Tau Software with the 
Quartus II Software” in Quartus II Help
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Figure 3. Formal Verification Flow

The type of formal verification supported by the Quartus II software is 
equivalence checking, which compares the functional equivalence of the 
source design with the revised design by using mathematical techniques 
rather than by performing simulation using test vectors. Equivalence 
checking greatly decreases the time to verify the design. The Quartus II 
software allows you to verify the logical equivalence between the 
synthesized gate-level Verilog Quartus Mapping Files (.vqm) generated by 
an EDA synthesis tool and the Verilog Output Files (.vo) generated by the 
Quartus II software. For the Cadence Encounter Conformal software, the 
Quartus II software also allows you to verify the logical equivalence 
between RTL VHDL design files (.vhd) or Verilog HDL design files (.v) and 
Quartus II software–generated Verilog Output Files. Figure 4 shows which 
file types are compared in formal verification.
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Figure 4. File Types Compared in Formal Verification

Using the Cadence Encounter 
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You can use the Cadence Encounter Conformal software to perform formal 
verification on your Quartus II designs. The formal verification software 
determines whether or not the Quartus II software correctly interprets the 
logic in the Verilog Quartus Mapping file or the source VHDL or 
Verilog HDL design file during synthesis and fitting.
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f For Information About Refer To

Using Cadence Encounter Conformal 
software

Cadence Encounter Conformal Support 
chapter in volume 3 of the Quartus II 
Handbook

“About Using the Encounter Conformal 
Software with the Quartus II Software” in 
Quartus II Help
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Installing the Quartus II Software
You can install the Quartus II software on the following platforms:

■ Pentium III (866 MHz or faster) based computer, running Microsoft 
Windows.
– PCs running Windows XP are capable of running the 32-bit 

version of the Quartus II software with access to virtual memory 
of 2 GB.

– PCs running Windows XP Professional x64 Edition or Windows 
Vista are capable of running the 32-bit version of the Quartus II 
software with access to virtual memory of up to 4 GB and the 
64-bit version of the Quartus II software with access to virtual 
memory of more than 4 GB.

■ One of the following Linux workstations:
– Intel Pentium III or compatible processor-based PC operating at 

450 MHz or faster with 256 MB of system memory, running Red 
Hat Enterprise Linux; CentOS; or SUSE Linux Enterprise (32-bit).

– AMD64 processor, Intel EM64T processor, or compatible 
processor-based PC with 1 GB of system memory, running Red 
Hat Enterprise Linux; CentOS; or SUSE Linux Enterprise Server 
(64-bit).

f For Information About Refer To

System requirements and installation 
instructions

Altera Software Installation and Licensing 
manual on the Altera website

Specific information about disk space 
and memory

Altera Complete Design Suite readme.txt 
file

Latest information on new features, 
EDA interface support, and known 
issues and workarounds for the 
Quartus II software

Quartus II Software Release Notes on the 
Altera website

Latest information about device 
support in the Quartus II software

Quartus II Device Support Release Notes on 
the Altera website
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Licensing the Quartus II Software
To use Altera-provided software, you need to obtain and set up an Altera 
subscription license. An Altera subscription enables the following software:

■ Altera Quartus II software (Includes SOPC Builder and IP Library)
■ Mentor Graphics ModelSim-Altera software

Altera offers several types of software subscriptions. Table 1 shows the 
different license and subscription options that are available.

Customers who purchase selected development kits receive a free version of 
the Quartus II software for Windows and are given instructions on how to 
obtain a license for the software.

Getting Technical Support
The easiest way to get technical support is to use the mySupport website and 
register for a myAltera account and user name. Your copy of the Quartus II 
software is registered at the time of purchase; however, in order to use the 

Table 1. Altera License and Subscription Options

License Type Description

Fixed License A stand-alone PC license tied to your Network 
Interface Card (NIC) number or Quartus II serial 
number.

Floating License A floating network (multiuser) license. Floating 
licenses are not operating system-specific.

f For Information About Refer To

Detailed information about licensing 
the Quartus II software, modifying the 
license file, and specifying the license 
file location

Altera Software Installation and Licensing 
manual on the Altera website

General information about Quartus II 
licensing

“Specifying a License File” in Quartus II Help
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mySupport website to view and submit service requests, you must also 
register for a myAltera account and user name. A myAltera account also 
makes it easier for you to use many other Altera website features, such as the 
Download Center, Self Service Licensing Center, Altera Technical Training 
online class registration, or Buy On-Line-Altera eStore features.

To register for a myAltera account user name and password, follow these 
steps:

1. Go to the mySupport website:

v To start your web browser and connect to the mySupport website 
while running the Quartus II software, on the Help menu point to 
Altera on the Web and click Quartus II Home Page.

or

v Point your web browser to the mySupport website at 
www.altera.com/mysupport.

2. Follow the instructions on the mySupport website to register for a 
myAltera account.

If you are not a current Altera subscription user, you can still register for an 
myAltera account. 

For information about other technical support resources, refer to Table 2. 

Table 2. Quartus II Technical Support Resources (Part 1 of 2)

Resource Description

Altera website www.altera.com

The Altera website provides information on Altera and all of 
its products.

Support Center www.altera.com/support

The Support Center section of the Altera website gives you 
access to the mySupport website. In addition, it provides 
software and device support information as well as design 
examples that you can integrate into your design.
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Getting Online Help
The Quartus II software includes a browser-based Help system that 
provides comprehensive documentation for the Quartus II software and 
more details about the specific messages generated by the Quartus II 
software. You can view Help in one of the following ways:

■ Click the Help button when available in an active dialog box.
■ On the Help menu, click Search.

To print Help topics from the Contents tab, right-click the individual Help 
topic that you want to print and click Print, or click the Print button on the 
toolbar. You can also use the Print command or Print button to print any 
individual Help topic you are viewing. 

To search for a keyword in an open Quartus II Help topic, press Ctrl+F to 
open the Find dialog box, and type the search text, and then click Find Next.

mySupport website www.altera.com/mysupport

The mySupport website allows you to submit, view, and 
update technical support service requests.

Telephone (800) 800-EPLD
(7:00 a.m. to 5:00 p.m. Pacific time, M–F)
You will need your 6-digit Altera ID to access the hotline.

(408) 544-8767
(7:00 a.m. to 5:00 p.m. Pacific time, M–F)

Table 2. Quartus II Technical Support Resources (Part 2 of 2)

Resource Description

f For Information About Refer To

Using Quartus II Help “Using Quartus II Help Effectively” and 
“Help Menu Commands” in Quartus II Help

“Using Quartus II Help” in the Altera 
Software Installation and Licensing manual.
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Starting the Quartus II Interactive 
Tutorial

The Quartus II software includes the Flash-based Quartus II Interactive 
Tutorial. The modules of this tutorial teach you how to use the basic features 
of the Quartus II design software, including design entry, compilation, 
timing analysis, programming, incremental compilation, and the SignalTap 
II Logic Analyzer.

This tutorial includes audio and Flash animation components. For best 
results, use the tutorial on a system that includes a sound card, speakers, and 
at least 1024x768 display resolution.

To start the Quartus II Interactive Tutorial after you have successfully 
installed the Quartus II software:

v On the Help menu, click Getting Started Tutorial.

Once you start the tutorial, you can jump immediately to any tutorial 
module by clicking Contents. Once you select a tutorial module, you can 
click Show Me, Guide Me, or Test Me at any time to jump directly to the 
tutorial mode that best suits your learning style.
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Other Quartus II Software 
Documentation

Table 3 shows the additional software documentation that is available for 
the Quartus II software:

Table 3. Additional Quartus II Documentation (Part 1 of 2)

Document Description Where to Find It

Quartus II Software Release 
Notes

Provides late-breaking 
information about new 
features, EDA interface 
support, and known issues 
and workarounds

The Altera website

Quartus II Device Support 
Release Notes

Provides information about 
changes to device support, 
including changes to 
timing, simulation, and 
power models

The Altera website

Altera Software Installation 
and Licensing manual

Provides detailed 
information about software 
requirements, installation, 
and licensing for Windows 
and Linux workstations

The Altera website

Quartus II Handbook Provides comprehensive 
information about the 
programmable logic design 
cycle from design to 
verification

In Quartus II subscription 
packages and on the Altera 
website

Altera Complete Design 
Suite readme.txt file

Provides information about 
memory, disk space, and 
system requirements

On the Altera Complete 
Design Suite DVD and 
installed with the Quartus II 
software

Quartus II Scripting 
Reference Manual

Provides information about 
command-line and Tcl 
commands and scripting

The Altera website
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Other Altera Literature
The Literature section of the Altera website at www.altera.com provides 
documentation on many subjects that are related to the Quartus II software, 
including the following topics:

■ Quartus II features and guidelines on using these features with your 
design flow

■ Altera device features, functions, structure, specifications, 
configuration, and pin-outs

■ Design solutions and methodologies
■ Implementing device features
■ Altera programming hardware features, use, and installation
■ Using the Quartus II software with other EDA tools
■ Using other Altera software tools
■ Implementing IP MegaCore functions and Altera megafunctions
■ Optimizing designs or improving performance
■ Synthesis, simulation, and verification guidelines
■ Product updates and notifications

The literature that is available from the Altera website is the most current 
information about Altera products and features; it is updated frequently, 
even after a product has been released. Altera continues to add new 
literature in order to provide more information on the latest features of 
Altera tools and devices, and to provide additional information that Altera 
customers have requested.

Quartus II Settings File 
Reference Manual

Provides information about 
Quartus II Settings File 
variables

The Altera website

Quartus II Software Quick 
Start Guide

Shows how to set up your 
project, set timing 
requirements, and compile 
your project for a target 
device

In Quartus II subscription 
packages and on the Altera 
website

Table 3. Additional Quartus II Documentation (Part 2 of 2)

Document Description Where to Find It
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Documentation Conventions
The Introduction to the Quartus II Software manual uses the following 
conventions to make it easy for you to find and interpret information.

Typographic Conventions

Quartus II documentation uses the typographic conventions shown in the 
following table:

Visual Cue Meaning

Bold Initial 
Capitals

Command names; dialog box, page, and tab titles; and button names 
are shown in bold, with initial capital letters. For example: Find Text 
command, Save As dialog box, and Start button.

bold Directory, project, disk drive, file names, file extensions, software 
utility and software executable names; file name extensions, and 
options in dialog boxes are shown in bold. Examples: quartus 
directory, d: drive, license.dat file. 

Initial Capitals Keyboard keys, user-editable application window fields, window 
names, view names, and menu names are shown with initial capital 
letters. For example: Delete key, the Options menu.

“Subheading 
Title”

Subheadings within a manual section are enclosed in quotation 
marks. In manuals, titles of Help topics are also shown in quotation 
marks.

Italic Initial 
Capitals

Help categories, manual titles, section titles in manuals, and 
application note and brief names are shown in italics with initial 
capital letters. For example: Introduction to the Quartus II Software.

italics Variables are enclosed in angle brackets (< >) and shown in italics. 
For example: <file name>, <DVD drive>.

Courier font Anything that must be typed exactly as it appears is shown in 
Courier. For example: \quartus\bin\lmutil lmhostid.

r Enter or return key.

■ Bullets are used in a list of items when the sequence of the items is 
not important.

f The feet show you where to go for more information on a particular 
topic.

v The checkmark indicates a procedure that consists of one step only.

! The hand points to information that requires special attention.
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Terminology

The following table shows terminology that is used throughout the 
Introduction to the Quartus II Software manual:

Term Meaning

“click” Indicates a quick press and release of the left mouse button. It 
also indicates that you need to use a mouse or key combination 
to start an action.

“double-click” Indicates two clicks in rapid succession.

“select” Indicates that you need to highlight text and/or objects or an 
option in a dialog box with a key combination or the mouse. A 
selection does not start an action. For example: Select Chain 
Description File, and then click OK.

“point” Indicates that you need to position the mouse pointer, without 
clicking, at an appropriate location on the screen, such as a 
menu or submenu. For example: On the Help menu, point to 
Altera on the Web, and then click Quartus II Service 
Request.

turn on/turn off Indicates that you must click a check box to turn a function on 
or off.
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